Social Icons

Work with multiple jQuery versions in same page





Though it is not recommended to use multiple versions of jQuery together in same page, but it sometimes becomes a pressing need for developers to use more than one versions of jQuery on same page. This situation might occur in a scenario where a thrid party plugin is dependent on a particular version on jQuery, and you might simultaneously want to use a latest feature of the jQuery. Thus to enjoy the both worlds you would need to use more than one versions of jQuery.

The following simple steps shows how to do it:

Add a jQuery version to your page and create an alias of it as below:


Next, add the other jQuery version and similarly create another alias:


Finally, use the individual aliases to use that particular jQuery version:


Full code example given below:

0 comments:

Post a Comment